TaskThreadingLib Namespace

Documentacion de TaskThreadingLib
TaskThreadingLib Namespace
Espacio de nombres ► TaskThreadingLib
Declaration Syntax
C# Visual Basic Visual C++
namespace TaskThreadingLib
Namespace TaskThreadingLib
namespace TaskThreadingLib
Types
All Types Classes Delegates
Icon | Type | Description
 | AsyncMethods | Clase que ejecuta metodos de forma asincrona mediante delegados
 | AsyncMethods..::.MethodHandler | Delegado para ejecutar un metodo que se declara como void y no toma ningun parametro
 | AsyncMethods..::.MethodParamsHandler | Delegado para ejecutar un metodo que se declara como void y puede tomar parametros
 | RaiseEvents | Clase que contiene metodos para lanzar los eventos desde el contexto de subprocesamientos
 | ThreadingBase | Clase base donde se inicia el contexto de subprocesamientos
 | ThreadingSyncContext | Clase de la cual van a hereder las clases que requieran funcionalidad de subprocesamiento
 | AsyncMethods..::.TMethodHandler<(Of <(T>)>) | Delegado para ejecutar un metodo que puede devolver un tipo y no toma ningun parametro
 | AsyncMethods..::.TMethodParamsHandler<(Of <(T>)>) | Delegado para ejecutar un metodo que puede devolver un tipo y puede tomar parametros


AsyncMethods Class

AsyncMethods Class
Espacio de nombres ► TaskThreadingLib ► AsyncMethods
Clase que ejecuta metodos de forma asincrona mediante delegados
Declaration Syntax
C# Visual Basic Visual C++
public abstract class AsyncMethods : RaiseEvents
Public MustInherit Class AsyncMethods _
    Inherits RaiseEvents
public ref class AsyncMethods abstract : public RaiseEvents
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AsyncMethods()()() |
 | AsyncMethods(SynchronizationContext) |
 | CallAsyncMethod(AsyncMethods..::.MethodHandler, AsyncCallback) | Llama asincronamente un metodo que se declara como void y no toma ningun parametro
 | CallAsyncMethod<(Of <(T>)>)(AsyncMethods..::.TMethodHandler<(Of <(T>)>), AsyncCallback) | Llama asincronamente un metodo que puede devolver un tipo y no toma ningun parametro
 | CallAsyncMethod(AsyncMethods..::.MethodParamsHandler, AsyncCallback, array<Object>[]()[]) | Llama asincronamente un metodo que se declara como void y puede tomar parametros
 | CallAsyncMethod<(Of <(T>)>)(AsyncMethods..::.TMethodParamsHandler<(Of <(T>)>), AsyncCallback, array<Object>[]()[]) | Llama asincronamente un metodo que se puede devolver un tipo y puede tomar parametros
 | PostEvent(EventHandler, Object, EventArgs) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro. (Inherited from ThreadingBase.)
 | PostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro. (Inherited from ThreadingBase.)
 | RaisePostEvent(EventHandler, Object, EventArgs) | Lanza el evento que le es pasado como parametro de forma asincronica usando un contexto de sincronizacion (Inherited from RaiseEvents.)
 | RaisePostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Lanza el evento que le es pasado como parametro de forma asincronica usando un contexto de sincronizacion (Inherited from RaiseEvents.)
 | RaiseSendEvent(EventHandler, Object, EventArgs) | Lanza el evento que le es pasado como parametro de forma sincronica usando un contexto de sincronizacion (Inherited from RaiseEvents.)
 | RaiseSendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Lanza el evento que le es pasado como parametro de forma sincronica usando un contexto de sincronizacion (Inherited from RaiseEvents.)
 | SendEvent(EventHandler, Object, EventArgs) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro. (Inherited from ThreadingBase.)
 | SendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro. (Inherited from ThreadingBase.)
Remarks

[Missing <remarks> documentation for T:TaskThreadingLib.AsyncMethods]

Inheritance Hierarchy
Object
 | ThreadingBase
 |  | RaiseEvents
 |  |  | AsyncMethods
 |  |  |  | ThreadingSyncContext

Assembly: TaskThreadingLib (Módulo: TaskThreadingLib) Versión: 0.2.3086.39763 (0.2.0.0)


AsyncMethods Constructor

AsyncMethods Constructor
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► AsyncMethods()()()
Members
Icon | Member | Description
 | AsyncMethods()()() |
 | AsyncMethods(SynchronizationContext) |


AsyncMethods Constructor

AsyncMethods Constructor
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► AsyncMethods()()()
Initializes a new instance of the AsyncMethods class.
Declaration Syntax
C# Visual Basic Visual C++
protected AsyncMethods()
Protected Sub New
protected:
AsyncMethods()
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.AsyncMethods.#ctor]


AsyncMethods Constructor (syncContext)

AsyncMethods Constructor (syncContext)
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► AsyncMethods(SynchronizationContext)
Initializes a new instance of the AsyncMethods class.
Declaration Syntax
C# Visual Basic Visual C++
protected AsyncMethods(
    SynchronizationContext syncContext
)
Protected Sub New ( _
    syncContext As SynchronizationContext _
)
protected:
AsyncMethods(
    SynchronizationContext^ syncContext
)
Parameters
syncContext (SynchronizationContext)

[Missing <param> documentation for "syncContext"]

Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.AsyncMethods.#ctor(System.Threading.SynchronizationContext)]


CallAsyncMethod Method

CallAsyncMethod Method
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► CallAsyncMethod()()()
Members
Icon | Member | Description
 | CallAsyncMethod(AsyncMethods..::.MethodHandler, AsyncCallback) | Llama asincronamente un metodo que se declara como void y no toma ningun parametro
 | CallAsyncMethod<(Of <(T>)>)(AsyncMethods..::.TMethodHandler<(Of <(T>)>), AsyncCallback) | Llama asincronamente un metodo que puede devolver un tipo y no toma ningun parametro
 | CallAsyncMethod(AsyncMethods..::.MethodParamsHandler, AsyncCallback, array<Object>[]()[]) | Llama asincronamente un metodo que se declara como void y puede tomar parametros
 | CallAsyncMethod<(Of <(T>)>)(AsyncMethods..::.TMethodParamsHandler<(Of <(T>)>), AsyncCallback, array<Object>[]()[]) | Llama asincronamente un metodo que se puede devolver un tipo y puede tomar parametros


CallAsyncMethod Method (method, callback)

CallAsyncMethod Method (method, callback)
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► CallAsyncMethod(AsyncMethods..::.MethodHandler, AsyncCallback)
Llama asincronamente un metodo que se declara como void y no toma ningun parametro
Declaration Syntax
C# Visual Basic Visual C++
protected void CallAsyncMethod(
    AsyncMethods..::.MethodHandler method,
    AsyncCallback callback
)
Protected Sub CallAsyncMethod ( _
    method As AsyncMethods..::.MethodHandler, _
    callback As AsyncCallback _
)
protected:
void CallAsyncMethod(
    AsyncMethods..::.MethodHandler^ method,
    AsyncCallback^ callback
)
Parameters
method (AsyncMethods..::.MethodHandler)
Delegado a llamar asincronamente
callback (AsyncCallback)
Retrollamada
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.AsyncMethods.CallAsyncMethod(TaskThreadingLib.AsyncMethods.MethodHandler,System.AsyncCallback)]


CallAsyncMethod Method (method, callback, objs)

CallAsyncMethod Method (method, callback, objs)
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► CallAsyncMethod(AsyncMethods..::.MethodParamsHandler, AsyncCallback, array<Object>[]()[])
Llama asincronamente un metodo que se declara como void y puede tomar parametros
Declaration Syntax
C# Visual Basic Visual C++
protected void CallAsyncMethod(
    AsyncMethods..::.MethodParamsHandler method,
    AsyncCallback callback,
    params Object[] objs
)
Protected Sub CallAsyncMethod ( _
    method As AsyncMethods..::.MethodParamsHandler, _
    callback As AsyncCallback, _
    ParamArray objs As Object() _
)
protected:
void CallAsyncMethod(
    AsyncMethods..::.MethodParamsHandler^ method,
    AsyncCallback^ callback,
    ... array<Object^>^ objs
)
Parameters
method (AsyncMethods..::.MethodParamsHandler)
Delegado a llamar asincronamente
callback (AsyncCallback)
Retrollamada
objs (array< Object >[]()[])
Parametros del metodo
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.AsyncMethods.CallAsyncMethod(TaskThreadingLib.AsyncMethods.MethodParamsHandler,System.AsyncCallback,System.Object[])]


CallAsyncMethod Method (method, callback)

CallAsyncMethod<(Of <(T>)>) Method (method, callback)
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► CallAsyncMethod<(Of <(T>)>)(AsyncMethods..::.TMethodHandler<(Of <(T>)>), AsyncCallback)
Llama asincronamente un metodo que puede devolver un tipo y no toma ningun parametro
Declaration Syntax
C# Visual Basic Visual C++
protected void CallAsyncMethod<T>(
    AsyncMethods..::.TMethodHandler<T> method,
    AsyncCallback callback
)
Protected Sub CallAsyncMethod(Of T) ( _
    method As AsyncMethods..::.TMethodHandler(Of T), _
    callback As AsyncCallback _
)
protected:
generic<typename T>
void CallAsyncMethod(
    AsyncMethods..::.TMethodHandler<T>^ method,
    AsyncCallback^ callback
)
Generic Template Parameters
T
Tipo generico
Parameters
method (AsyncMethods..::.TMethodHandler <(Of <(T>)>))
Delegado a llamar asincronamente
callback (AsyncCallback)
Retrollamada
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.AsyncMethods.CallAsyncMethod``1(TaskThreadingLib.AsyncMethods.TMethodHandler{``0},System.AsyncCallback)]


CallAsyncMethod Method (method, callback, objs)

CallAsyncMethod<(Of <(T>)>) Method (method, callback, objs)
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► CallAsyncMethod<(Of <(T>)>)(AsyncMethods..::.TMethodParamsHandler<(Of <(T>)>), AsyncCallback, array<Object>[]()[])
Llama asincronamente un metodo que se puede devolver un tipo y puede tomar parametros
Declaration Syntax
C# Visual Basic Visual C++
protected void CallAsyncMethod<T>(
    AsyncMethods..::.TMethodParamsHandler<T> method,
    AsyncCallback callback,
    params Object[] objs
)
Protected Sub CallAsyncMethod(Of T) ( _
    method As AsyncMethods..::.TMethodParamsHandler(Of T), _
    callback As AsyncCallback, _
    ParamArray objs As Object() _
)
protected:
generic<typename T>
void CallAsyncMethod(
    AsyncMethods..::.TMethodParamsHandler<T>^ method,
    AsyncCallback^ callback,
    ... array<Object^>^ objs
)
Generic Template Parameters
T
Tipo generico
Parameters
method (AsyncMethods..::.TMethodParamsHandler <(Of <(T>)>))
Delegado a llamar asincronamente
callback (AsyncCallback)
Retrollamada
objs (array< Object >[]()[])
Parametros del metodo
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.AsyncMethods.CallAsyncMethod``1(TaskThreadingLib.AsyncMethods.TMethodParamsHandler{``0},System.AsyncCallback,System.Object[])]


AsyncMethods.MethodHandler Delegate

AsyncMethods..::.MethodHandler Delegate
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► AsyncMethods..::.MethodHandler
Delegado para ejecutar un metodo que se declara como void y no toma ningun parametro
Declaration Syntax
C# Visual Basic Visual C++
protected delegate void MethodHandler()
Protected Delegate Sub MethodHandler
protected delegate void MethodHandler()
Remarks

[Missing <remarks> documentation for T:TaskThreadingLib.AsyncMethods.MethodHandler]


AsyncMethods.MethodParamsHandler Delegate

AsyncMethods..::.MethodParamsHandler Delegate
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► AsyncMethods..::.MethodParamsHandler
Delegado para ejecutar un metodo que se declara como void y puede tomar parametros
Declaration Syntax
C# Visual Basic Visual C++
protected delegate void MethodParamsHandler(
    params Object[] objs
)
Protected Delegate Sub MethodParamsHandler ( _
    ParamArray objs As Object() _
)
protected delegate void MethodParamsHandler(
    ... array<Object^>^ objs
)
Parameters
objs (array< Object >[]()[])
Coleccion de parametros del metodo
Remarks

[Missing <remarks> documentation for T:TaskThreadingLib.AsyncMethods.MethodParamsHandler]


AsyncMethods.TMethodHandler(T) Delegate

AsyncMethods..::.TMethodHandler<(Of <(T>)>) Delegate
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► AsyncMethods..::.TMethodHandler<(Of <(T>)>)
Delegado para ejecutar un metodo que puede devolver un tipo y no toma ningun parametro
Declaration Syntax
C# Visual Basic Visual C++
protected delegate T TMethodHandler<T>()
Protected Delegate Function TMethodHandler(Of T) As T
generic<typename T>
protected delegate T TMethodHandler()
Generic Template Parameters
T
Tipo generico
Return Value
Devuelve cualquier tipo
Remarks

[Missing <remarks> documentation for T:TaskThreadingLib.AsyncMethods.TMethodHandler`1]


AsyncMethods.TMethodParamsHandler(T) Delegate

AsyncMethods..::.TMethodParamsHandler<(Of <(T>)>) Delegate
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► AsyncMethods..::.TMethodParamsHandler<(Of <(T>)>)
Delegado para ejecutar un metodo que puede devolver un tipo y puede tomar parametros
Declaration Syntax
C# Visual Basic Visual C++
protected delegate T TMethodParamsHandler<T>(
    params Object[] objs
)
Protected Delegate Function TMethodParamsHandler(Of T) ( _
    ParamArray objs As Object() _
) As T
generic<typename T>
protected delegate T TMethodParamsHandler(
    ... array<Object^>^ objs
)
Generic Template Parameters
T
Tipo generico
Parameters
objs (array< Object >[]()[])
Coleccion de parametros del metodo
Return Value
Devuelve cualquier tipo
Remarks

[Missing <remarks> documentation for T:TaskThreadingLib.AsyncMethods.TMethodParamsHandler`1]


RaiseEvents Class

RaiseEvents Class
Espacio de nombres ► TaskThreadingLib ► RaiseEvents
Clase que contiene metodos para lanzar los eventos desde el contexto de subprocesamientos
Declaration Syntax
C# Visual Basic Visual C++
public abstract class RaiseEvents : ThreadingBase
Public MustInherit Class RaiseEvents _
    Inherits ThreadingBase
public ref class RaiseEvents abstract : public ThreadingBase
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RaiseEvents()()() |
 | RaiseEvents(SynchronizationContext) |
 | PostEvent(EventHandler, Object, EventArgs) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro. (Inherited from ThreadingBase.)
 | PostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro. (Inherited from ThreadingBase.)
 | RaisePostEvent(EventHandler, Object, EventArgs) | Lanza el evento que le es pasado como parametro de forma asincronica usando un contexto de sincronizacion
 | RaisePostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Lanza el evento que le es pasado como parametro de forma asincronica usando un contexto de sincronizacion
 | RaiseSendEvent(EventHandler, Object, EventArgs) | Lanza el evento que le es pasado como parametro de forma sincronica usando un contexto de sincronizacion
 | RaiseSendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Lanza el evento que le es pasado como parametro de forma sincronica usando un contexto de sincronizacion
 | SendEvent(EventHandler, Object, EventArgs) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro. (Inherited from ThreadingBase.)
 | SendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro. (Inherited from ThreadingBase.)
Remarks

[Missing <remarks> documentation for T:TaskThreadingLib.RaiseEvents]

Inheritance Hierarchy
Object
 | ThreadingBase
 |  | RaiseEvents
 |  |  | AsyncMethods


RaiseEvents Constructor

RaiseEvents Constructor
Espacio de nombres ► TaskThreadingLib ► RaiseEvents ► RaiseEvents()()()
Members
Icon | Member | Description
 | RaiseEvents()()() |
 | RaiseEvents(SynchronizationContext) |


RaiseEvents Constructor

RaiseEvents Constructor
Espacio de nombres ► TaskThreadingLib ► RaiseEvents ► RaiseEvents()()()
Initializes a new instance of the RaiseEvents class.
Declaration Syntax
C# Visual Basic Visual C++
protected RaiseEvents()
Protected Sub New
protected:
RaiseEvents()
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.RaiseEvents.#ctor]


RaiseEvents Constructor (SyncContext)

RaiseEvents Constructor (SyncContext)
Espacio de nombres ► TaskThreadingLib ► RaiseEvents ► RaiseEvents(SynchronizationContext)
Initializes a new instance of the RaiseEvents class.
Declaration Syntax
C# Visual Basic Visual C++
protected RaiseEvents(
    SynchronizationContext SyncContext
)
Protected Sub New ( _
    SyncContext As SynchronizationContext _
)
protected:
RaiseEvents(
    SynchronizationContext^ SyncContext
)
Parameters
SyncContext (SynchronizationContext)

[Missing <param> documentation for "SyncContext"]

Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.RaiseEvents.#ctor(System.Threading.SynchronizationContext)]


RaisePostEvent Method

RaisePostEvent Method
Espacio de nombres ► TaskThreadingLib ► RaiseEvents ► RaisePostEvent()()()
Members
Icon | Member | Description
 | RaisePostEvent(EventHandler, Object, EventArgs) | Lanza el evento que le es pasado como parametro de forma asincronica usando un contexto de sincronizacion
 | RaisePostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Lanza el evento que le es pasado como parametro de forma asincronica usando un contexto de sincronizacion


RaisePostEvent Method (Event, sender, eventArgs)

RaisePostEvent Method (Event, sender, eventArgs)
Espacio de nombres ► TaskThreadingLib ► RaiseEvents ► RaisePostEvent(EventHandler, Object, EventArgs)
Lanza el evento que le es pasado como parametro de forma asincronica usando un contexto de sincronizacion
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void RaisePostEvent(
    EventHandler Event,
    Object sender,
    EventArgs eventArgs
)
Protected Overridable Sub RaisePostEvent ( _
    Event As EventHandler, _
    sender As Object, _
    eventArgs As EventArgs _
)
protected:
virtual void RaisePostEvent(
    EventHandler^ Event,
    Object^ sender,
    EventArgs^ eventArgs
)
Parameters
Event (EventHandler)
Evento que se va a lanzar asincronamente
sender (Object)
Objeto que lanza el evento
eventArgs (EventArgs)
Argumentos del evento
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.RaiseEvents.RaisePostEvent(System.EventHandler,System.Object,System.EventArgs)]


RaisePostEvent Method (Tevent, sender, TeventArgs)

RaisePostEvent<(Of <(T>)>) Method (Tevent, sender, TeventArgs)
Espacio de nombres ► TaskThreadingLib ► RaiseEvents ► RaisePostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T)
Lanza el evento que le es pasado como parametro de forma asincronica usando un contexto de sincronizacion
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void RaisePostEvent<T>(
    EventHandler<T> Tevent,
    Object sender,
    T TeventArgs
) where T : EventArgs
Protected Overridable Sub RaisePostEvent(Of T As EventArgs) ( _
    Tevent As EventHandler(Of T), _
    sender As Object, _
    TeventArgs As T _
)
protected:
generic<typename T>
where T : EventArgs
virtual void RaisePostEvent(
    EventHandler<T>^ Tevent,
    Object^ sender,
    T TeventArgs
)
Generic Template Parameters
T
Tipo generico que debe heredar de EventArgs
Parameters
Tevent (EventHandler <(Of <(T>)>))
Evento que se va a lanzar asincronamente
sender (Object)
Objeto que lanza el evento
TeventArgs (T)
Argumentos del evento
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.RaiseEvents.RaisePostEvent``1(System.EventHandler{``0},System.Object,``0)]


RaiseSendEvent Method

RaiseSendEvent Method
Espacio de nombres ► TaskThreadingLib ► RaiseEvents ► RaiseSendEvent()()()
Members
Icon | Member | Description
 | RaiseSendEvent(EventHandler, Object, EventArgs) | Lanza el evento que le es pasado como parametro de forma sincronica usando un contexto de sincronizacion
 | RaiseSendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Lanza el evento que le es pasado como parametro de forma sincronica usando un contexto de sincronizacion


RaiseSendEvent Method (Event, sender, eventArgs)

RaiseSendEvent Method (Event, sender, eventArgs)
Espacio de nombres ► TaskThreadingLib ► RaiseEvents ► RaiseSendEvent(EventHandler, Object, EventArgs)
Lanza el evento que le es pasado como parametro de forma sincronica usando un contexto de sincronizacion
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void RaiseSendEvent(
    EventHandler Event,
    Object sender,
    EventArgs eventArgs
)
Protected Overridable Sub RaiseSendEvent ( _
    Event As EventHandler, _
    sender As Object, _
    eventArgs As EventArgs _
)
protected:
virtual void RaiseSendEvent(
    EventHandler^ Event,
    Object^ sender,
    EventArgs^ eventArgs
)
Parameters
Event (EventHandler)
Evento que se va a lanzar sincronamente
sender (Object)
Objeto que lanza el evento
eventArgs (EventArgs)
Argumentos del evento
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.RaiseEvents.RaiseSendEvent(System.EventHandler,System.Object,System.EventArgs)]


RaiseSendEvent Method (Tevent, sender, TeventArgs)

RaiseSendEvent<(Of <(T>)>) Method (Tevent, sender, TeventArgs)
Espacio de nombres ► TaskThreadingLib ► RaiseEvents ► RaiseSendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T)
Lanza el evento que le es pasado como parametro de forma sincronica usando un contexto de sincronizacion
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void RaiseSendEvent<T>(
    EventHandler<T> Tevent,
    Object sender,
    T TeventArgs
) where T : EventArgs
Protected Overridable Sub RaiseSendEvent(Of T As EventArgs) ( _
    Tevent As EventHandler(Of T), _
    sender As Object, _
    TeventArgs As T _
)
protected:
generic<typename T>
where T : EventArgs
virtual void RaiseSendEvent(
    EventHandler<T>^ Tevent,
    Object^ sender,
    T TeventArgs
)
Generic Template Parameters
T
Tipo generico que debe heredar de EventArgs
Parameters
Tevent (EventHandler <(Of <(T>)>))
Evento que se va a lanzar sincronamente
sender (Object)
Objeto que lanza el evento
TeventArgs (T)
Argumentos del evento
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.RaiseEvents.RaiseSendEvent``1(System.EventHandler{``0},System.Object,``0)]


ThreadingBase Class

ThreadingBase Class
Espacio de nombres ► TaskThreadingLib ► ThreadingBase
Clase base donde se inicia el contexto de subprocesamientos
Declaration Syntax
C# Visual Basic Visual C++
public abstract class ThreadingBase
Public MustInherit Class ThreadingBase
public ref class ThreadingBase abstract
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ThreadingBase()()() | Inicia el contexto de sincronizacion de la operacion asincronica de la clase AsyncOperationManager
 | ThreadingBase(SynchronizationContext) | Inicia el contexto de sincronizacion que le es pasado como parametro
 | PostEvent(EventHandler, Object, EventArgs) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro.
 | PostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro.
 | SendEvent(EventHandler, Object, EventArgs) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro.
 | SendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro.
Remarks

[Missing <remarks> documentation for T:TaskThreadingLib.ThreadingBase]

Inheritance Hierarchy
Object
 | ThreadingBase
 |  | RaiseEvents


ThreadingBase Constructor

ThreadingBase Constructor
Espacio de nombres ► TaskThreadingLib ► ThreadingBase ► ThreadingBase()()()
Members
Icon | Member | Description
 | ThreadingBase()()() | Inicia el contexto de sincronizacion de la operacion asincronica de la clase AsyncOperationManager
 | ThreadingBase(SynchronizationContext) | Inicia el contexto de sincronizacion que le es pasado como parametro


ThreadingBase Constructor

ThreadingBase Constructor
Espacio de nombres ► TaskThreadingLib ► ThreadingBase ► ThreadingBase()()()
Inicia el contexto de sincronizacion de la operacion asincronica de la clase AsyncOperationManager
Declaration Syntax
C# Visual Basic Visual C++
protected ThreadingBase()
Protected Sub New
protected:
ThreadingBase()
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.ThreadingBase.#ctor]


ThreadingBase Constructor (SyncContext)

ThreadingBase Constructor (SyncContext)
Espacio de nombres ► TaskThreadingLib ► ThreadingBase ► ThreadingBase(SynchronizationContext)
Inicia el contexto de sincronizacion que le es pasado como parametro
Declaration Syntax
C# Visual Basic Visual C++
protected ThreadingBase(
    SynchronizationContext SyncContext
)
Protected Sub New ( _
    SyncContext As SynchronizationContext _
)
protected:
ThreadingBase(
    SynchronizationContext^ SyncContext
)
Parameters
SyncContext (SynchronizationContext)
Contexto de sincronizacion
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.ThreadingBase.#ctor(System.Threading.SynchronizationContext)]


PostEvent Method

PostEvent Method
Espacio de nombres ► TaskThreadingLib ► ThreadingBase ► PostEvent()()()
Members
Icon | Member | Description
 | PostEvent(EventHandler, Object, EventArgs) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro.
 | PostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro.


PostEvent Method (eventHandler, sender, eventArgs)

PostEvent Method (eventHandler, sender, eventArgs)
Espacio de nombres ► TaskThreadingLib ► ThreadingBase ► PostEvent(EventHandler, Object, EventArgs)
Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro.
Declaration Syntax
C# Visual Basic Visual C++
protected void PostEvent(
    EventHandler eventHandler,
    Object sender,
    EventArgs eventArgs
)
Protected Sub PostEvent ( _
    eventHandler As EventHandler, _
    sender As Object, _
    eventArgs As EventArgs _
)
protected:
void PostEvent(
    EventHandler^ eventHandler,
    Object^ sender,
    EventArgs^ eventArgs
)
Parameters
eventHandler (EventHandler)
Evento a llamar asincronamente
sender (Object)
Objeto que lanza el evento
eventArgs (EventArgs)
Argumentos del evento
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.ThreadingBase.PostEvent(System.EventHandler,System.Object,System.EventArgs)]


PostEvent Method (eventHandler, sender, eventArgs)

PostEvent<(Of <(T>)>) Method (eventHandler, sender, eventArgs)
Espacio de nombres ► TaskThreadingLib ► ThreadingBase ► PostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T)
Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro.
Declaration Syntax
C# Visual Basic Visual C++
protected void PostEvent<T>(
    EventHandler<T> eventHandler,
    Object sender,
    T eventArgs
) where T : EventArgs
Protected Sub PostEvent(Of T As EventArgs) ( _
    eventHandler As EventHandler(Of T), _
    sender As Object, _
    eventArgs As T _
)
protected:
generic<typename T>
where T : EventArgs
void PostEvent(
    EventHandler<T>^ eventHandler,
    Object^ sender,
    T eventArgs
)
Generic Template Parameters
T
Tipo generico que debe heredar de EventArgs
Parameters
eventHandler (EventHandler <(Of <(T>)>))
Evento a llamar asincronamente
sender (Object)
Objeto que lanza el evento
eventArgs (T)
Argumentos del evento
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.ThreadingBase.PostEvent``1(System.EventHandler{``0},System.Object,``0)]


SendEvent Method

SendEvent Method
Espacio de nombres ► TaskThreadingLib ► ThreadingBase ► SendEvent()()()
Members
Icon | Member | Description
 | SendEvent(EventHandler, Object, EventArgs) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro.
 | SendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro.


SendEvent Method (eventHandler, sender, eventArgs)

SendEvent Method (eventHandler, sender, eventArgs)
Espacio de nombres ► TaskThreadingLib ► ThreadingBase ► SendEvent(EventHandler, Object, EventArgs)
Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro.
Declaration Syntax
C# Visual Basic Visual C++
protected void SendEvent(
    EventHandler eventHandler,
    Object sender,
    EventArgs eventArgs
)
Protected Sub SendEvent ( _
    eventHandler As EventHandler, _
    sender As Object, _
    eventArgs As EventArgs _
)
protected:
void SendEvent(
    EventHandler^ eventHandler,
    Object^ sender,
    EventArgs^ eventArgs
)
Parameters
eventHandler (EventHandler)
Evento a llamar sincronamente
sender (Object)
Objeto que lanza el evento
eventArgs (EventArgs)
Argumentos del evento
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.ThreadingBase.SendEvent(System.EventHandler,System.Object,System.EventArgs)]


SendEvent Method (eventHandler, sender, eventArgs)

SendEvent<(Of <(T>)>) Method (eventHandler, sender, eventArgs)
Espacio de nombres ► TaskThreadingLib ► ThreadingBase ► SendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T)
Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro.
Declaration Syntax
C# Visual Basic Visual C++
protected void SendEvent<T>(
    EventHandler<T> eventHandler,
    Object sender,
    T eventArgs
) where T : EventArgs
Protected Sub SendEvent(Of T As EventArgs) ( _
    eventHandler As EventHandler(Of T), _
    sender As Object, _
    eventArgs As T _
)
protected:
generic<typename T>
where T : EventArgs
void SendEvent(
    EventHandler<T>^ eventHandler,
    Object^ sender,
    T eventArgs
)
Generic Template Parameters
T
Tipo generico que debe heredar de EventArgs
Parameters
eventHandler (EventHandler <(Of <(T>)>))
Evento a llamar sincronamente
sender (Object)
Objeto que lanza el evento
eventArgs (T)
Argumentos del evento
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.ThreadingBase.SendEvent``1(System.EventHandler{``0},System.Object,``0)]


ThreadingSyncContext Class

ThreadingSyncContext Class
Espacio de nombres ► TaskThreadingLib ► ThreadingSyncContext
Clase de la cual van a hereder las clases que requieran funcionalidad de subprocesamiento
Declaration Syntax
C# Visual Basic Visual C++
public abstract class ThreadingSyncContext : AsyncMethods
Public MustInherit Class ThreadingSyncContext _
    Inherits AsyncMethods
public ref class ThreadingSyncContext abstract : public AsyncMethods
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ThreadingSyncContext()()() |
 | ThreadingSyncContext(SynchronizationContext) |
 | CallAsyncMethod(AsyncMethods..::.MethodHandler, AsyncCallback) | Llama asincronamente un metodo que se declara como void y no toma ningun parametro (Inherited from AsyncMethods.)
 | CallAsyncMethod<(Of <(T>)>)(AsyncMethods..::.TMethodHandler<(Of <(T>)>), AsyncCallback) | Llama asincronamente un metodo que puede devolver un tipo y no toma ningun parametro (Inherited from AsyncMethods.)
 | CallAsyncMethod(AsyncMethods..::.MethodParamsHandler, AsyncCallback, array<Object>[]()[]) | Llama asincronamente un metodo que se declara como void y puede tomar parametros (Inherited from AsyncMethods.)
 | CallAsyncMethod<(Of <(T>)>)(AsyncMethods..::.TMethodParamsHandler<(Of <(T>)>), AsyncCallback, array<Object>[]()[]) | Llama asincronamente un metodo que se puede devolver un tipo y puede tomar parametros (Inherited from AsyncMethods.)
 | PostEvent(EventHandler, Object, EventArgs) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro. (Inherited from ThreadingBase.)
 | PostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro. (Inherited from ThreadingBase.)
 | RaisePostEvent(EventHandler, Object, EventArgs) | Lanza el evento que le es pasado como parametro de forma asincronica usando un contexto de sincronizacion (Inherited from RaiseEvents.)
 | RaisePostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Lanza el evento que le es pasado como parametro de forma asincronica usando un contexto de sincronizacion (Inherited from RaiseEvents.)
 | RaiseSendEvent(EventHandler, Object, EventArgs) | Lanza el evento que le es pasado como parametro de forma sincronica usando un contexto de sincronizacion (Inherited from RaiseEvents.)
 | RaiseSendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Lanza el evento que le es pasado como parametro de forma sincronica usando un contexto de sincronizacion (Inherited from RaiseEvents.)
 | SendEvent(EventHandler, Object, EventArgs) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro. (Inherited from ThreadingBase.)
 | SendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro. (Inherited from ThreadingBase.)
Remarks
Esta libreria tiene 2 propositos principales que son. 1.- Usar un contexto de subprocesamientos libres de sincronizacion, esto es usado por ejemplo para modificar la interfaz de usuario sin necesidad de invocarlo desde el hilo de la interfaz de usuario, etc. 2.- Llamar a metodos de forma asincrona por medio de delegados. Veamos los siguientes ejemplos usando diferentes escenarios.
Examples
El siguiente ejemplo muestra como llamar un metodo de forma asincronica, este metodo se declara como void y no toma parametros.
CopyC#
using System.Threading;
using TaskThreadingLib;

public class Clase : ThreadingSyncContext
{
    public void Metodo()
    {
        Console.WriteLine("En espera por 2 segundos");
        Thread.Sleep(2000);
    }

    // Llamada asincrona
    pubic void AsyncMetodo()
    {
        base.CallAsyncMethod((MethodHandler)
        delegate
        {
            this.Metodo();
        },
        new AsyncCallback(this.Callback));
    }

    private void Callback(IAsyncResult ar)
    {
        if (ar.IsCompleted) {
            Console.WriteLine("Termino el metodo");
        }
    }
}
 El siguiente ejemplo muestra como llamar un metodo de forma asincronica, este metodo devuelte un tipo y no toma parametros.
CopyC#
using System.Threading;
using TaskThreadingLib;

public class Clase : ThreadingSyncContext
{
    public int Metodo()
    {
        return 4 * 5 + 32;
    }

    // Llamada asincrona
    pubic void AsyncMetodo()
    {
        base.CallAsyncMethod<int>((TMethodHandler<int>)
        delegate
        {
            return this.Metodo();
        },
        new AsyncCallback(this.Callback));
    }

    private void Callback(IAsyncResult ar)
    {
        if (ar.IsCompleted) {
            TMethodHandler<int> M = (TMethodHandler<int>)ar.AsyncState;
            Console.WriteLine("El metodo devolvio {0}" M.EndInvoke(ar).ToString());
        }
    }
}
 El siguiente ejemplo muestra como llamar un metodo de forma asincronica, este metodo se declara como void y puede tomar parametros.
CopyC#
using System.Threading;
using TaskThreadingLib;

public class Clase : ThreadingSyncContext
{
    public void Metodo(double x, double y)
    {
        Console.WriteLine((x * y).ToString());
    }

    // Llamada asincrona
    pubic void AsyncMetodo(duble x, double y)
    {
        base.CallAsyncMethod((MethodParamsHandler)
        delegate(objects[] objs)
        {
            this.Metodo((double)objs[0], (double)objs[1]);
        },
        new AsyncCallback(this.Callback), new object[] { x, y });
    }

    private void Callback(IAsyncResult ar)
    {
        if (ar.IsCompleted) {
            Console.WriteLine("Termino el metodo");
        }
    }
}
 El siguiente ejemplo muestra como llamar un metodo de forma asincronica, este metodo devuelte un tipo y puede tomar parametros.
CopyC#
using System.Threading;
using TaskThreadingLib;

public class Clase : ThreadingSyncContext
{
    public double Metodo(double x, double y)
    {
        return x * y;
    }

    // Llamada asincrona
    pubic void AsyncMetodo(duble x, double y)
    {
        base.CallAsyncMethod<double>((TMethodParamsHandler<double>)
        delegate(objects[] objs)
        {
            return this.Metodo((double)objs[0], (double)objs[1]);
        },
        new AsyncCallback(this.Callback), new object[] { x, y });
    }

    private void Callback(IAsyncResult ar)
    {
        if (ar.IsCompleted) {
            TMethodParamsHandler<double> M = (TMethodParamsHandler<int>)ar.AsyncState;
            Console.WriteLine("El metodo devolvio {0}" M.EndInvoke(ar).ToString());
        }
    }
}
 El siguiente ejemplo lanza un evento desde un metodo sincronico, este metodo acepta valores en el eventargs. Asi que creamos la clase que le vamos a pasar a los argumentos del evento.
CopyC#
public class TArgs : EventArgs
{
    private string str = string.Empty;

    public TArgs(string Str)
    {
        this.str = Str;
    }

    public string STR
    {
        get {
            return this.str;
        }
    }
}
 Ahora la clase que contiene el metodo sincronico que lanzara el evento.
CopyC#
using System.Threading;
using TaskThreadingLib;

public class Clase : ThreadingSyncContext
{
    public EventHandler<TArgs> evento = null;

    public void Metodo()
    {
        // Aqui lanzamos el evento usando el contexto de sincronizacion.
        base.RaisePostEvent<TArgs>(evento, this, new TArgs("ManagedThreadId " +
        Thread.CurrentThread.ManagedThreadId.ToString()));

        Thread.Sleep(2000);
    }

    // Llamada asincrona
    pubic void AsyncMetodo()
    {
        base.CallAsyncMethod((MethodHandler)
        delegate
        {
            this.Metodo();
        },
        new AsyncCallback(this.Callback));
    }

    private void Callback(IAsyncResult ar)
    {
        if (ar.IsCompleted) {
            Console.WriteLine("Termino el metodo");
        }
    }
}
 Ahora la forma de usar la clase por ejemplo en un formulario u otra clase. En este caso vamos a suponer que lo llamamos desde un boton y queremos modificar una etiqueta con los valores de los argumentos de un evento
CopyC#
private void button1_Click(object sender, EventArgs e)
{
    Clase claseT = new Clase(WindowsFormsSynchronizationContext.Current);
    claseT.event += new EventHandler<TArgs>(eventH);

    t.AsyncMetodo();
}

private void eventH(object sender, TArgs args)
{
    this.lblEtiqueta.Text = args.STR;
}
 Hay muchos mas escenarios y formas de usar los metodos y delegados de estas clases. Hay que escoger la forma que creamos mas conveniente para cada caso.
Inheritance Hierarchy
Object
 | ThreadingBase
 |  | RaiseEvents
 |  |  | AsyncMethods
 |  |  |  | ThreadingSyncContext


ThreadingSyncContext Constructor

ThreadingSyncContext Constructor
Espacio de nombres ► TaskThreadingLib ► ThreadingSyncContext ► ThreadingSyncContext()()()
Members
Icon | Member | Description
 | ThreadingSyncContext()()() |
 | ThreadingSyncContext(SynchronizationContext) |


ThreadingSyncContext Constructor

ThreadingSyncContext Constructor
Espacio de nombres ► TaskThreadingLib ► ThreadingSyncContext ► ThreadingSyncContext()()()
Initializes a new instance of the ThreadingSyncContext class.
Declaration Syntax
C# Visual Basic Visual C++
protected ThreadingSyncContext()
Protected Sub New
protected:
ThreadingSyncContext()
Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.ThreadingSyncContext.#ctor]


ThreadingSyncContext Constructor (SyncContext)

ThreadingSyncContext Constructor (SyncContext)
Espacio de nombres ► TaskThreadingLib ► ThreadingSyncContext ► ThreadingSyncContext(SynchronizationContext)
Initializes a new instance of the ThreadingSyncContext class.
Declaration Syntax
C# Visual Basic Visual C++
protected ThreadingSyncContext(
    SynchronizationContext SyncContext
)
Protected Sub New ( _
    SyncContext As SynchronizationContext _
)
protected:
ThreadingSyncContext(
    SynchronizationContext^ SyncContext
)
Parameters
SyncContext (SynchronizationContext)

[Missing <param> documentation for "SyncContext"]

Remarks

[Missing <remarks> documentation for M:TaskThreadingLib.ThreadingSyncContext.#ctor(System.Threading.SynchronizationContext)]


SendEvent Method

SendEvent Method
Espacio de nombres ► TaskThreadingLib ► ThreadingSyncContext ► SendEvent()()()
Members
Icon | Member | Description
 | SendEvent(EventHandler, Object, EventArgs) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro.
 | SendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro.


PostEvent Method

PostEvent Method
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► PostEvent()()()
Members
Icon | Member | Description
 | PostEvent(EventHandler, Object, EventArgs) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro.
 | PostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro.


PostEvent Method

PostEvent Method
Espacio de nombres ► TaskThreadingLib ► ThreadingSyncContext ► PostEvent()()()
Members
Icon | Member | Description
 | PostEvent(EventHandler, Object, EventArgs) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro.
 | PostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro.


RaiseSendEvent Method

RaiseSendEvent Method
Espacio de nombres ► TaskThreadingLib ► ThreadingSyncContext ► RaiseSendEvent()()()
Members
Icon | Member | Description
 | RaiseSendEvent(EventHandler, Object, EventArgs) | Lanza el evento que le es pasado como parametro de forma sincronica usando un contexto de sincronizacion
 | RaiseSendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Lanza el evento que le es pasado como parametro de forma sincronica usando un contexto de sincronizacion


SendEvent Method

SendEvent Method
Espacio de nombres ► TaskThreadingLib ► RaiseEvents ► SendEvent()()()
Members
Icon | Member | Description
 | SendEvent(EventHandler, Object, EventArgs) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro.
 | SendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro.


CallAsyncMethod Method

CallAsyncMethod Method
Espacio de nombres ► TaskThreadingLib ► ThreadingSyncContext ► CallAsyncMethod()()()
Members
Icon | Member | Description
 | CallAsyncMethod(AsyncMethods..::.MethodHandler, AsyncCallback) | Llama asincronamente un metodo que se declara como void y no toma ningun parametro
 | CallAsyncMethod<(Of <(T>)>)(AsyncMethods..::.TMethodHandler<(Of <(T>)>), AsyncCallback) | Llama asincronamente un metodo que puede devolver un tipo y no toma ningun parametro
 | CallAsyncMethod(AsyncMethods..::.MethodParamsHandler, AsyncCallback, array<Object>[]()[]) | Llama asincronamente un metodo que se declara como void y puede tomar parametros
 | CallAsyncMethod<(Of <(T>)>)(AsyncMethods..::.TMethodParamsHandler<(Of <(T>)>), AsyncCallback, array<Object>[]()[]) | Llama asincronamente un metodo que se puede devolver un tipo y puede tomar parametros


RaiseSendEvent Method

RaiseSendEvent Method
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► RaiseSendEvent()()()
Members
Icon | Member | Description
 | RaiseSendEvent(EventHandler, Object, EventArgs) | Lanza el evento que le es pasado como parametro de forma sincronica usando un contexto de sincronizacion
 | RaiseSendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Lanza el evento que le es pasado como parametro de forma sincronica usando un contexto de sincronizacion


PostEvent Method

PostEvent Method
Espacio de nombres ► TaskThreadingLib ► RaiseEvents ► PostEvent()()()
Members
Icon | Member | Description
 | PostEvent(EventHandler, Object, EventArgs) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro.
 | PostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud asincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro.


RaisePostEvent Method

RaisePostEvent Method
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► RaisePostEvent()()()
Members
Icon | Member | Description
 | RaisePostEvent(EventHandler, Object, EventArgs) | Lanza el evento que le es pasado como parametro de forma asincronica usando un contexto de sincronizacion
 | RaisePostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Lanza el evento que le es pasado como parametro de forma asincronica usando un contexto de sincronizacion


SendEvent Method

SendEvent Method
Espacio de nombres ► TaskThreadingLib ► AsyncMethods ► SendEvent()()()
Members
Icon | Member | Description
 | SendEvent(EventHandler, Object, EventArgs) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler que le es pasado como parametro.
 | SendEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Inicia una solicitud sincronica ejecutando el evento de tipo EventHandler generico que le es pasado como parametro.


Namespaces

Namespaces
Espacio de nombres
Namespaces
Namespace | Description
TaskThreadingLib |


RaisePostEvent Method

RaisePostEvent Method
Espacio de nombres ► TaskThreadingLib ► ThreadingSyncContext ► RaisePostEvent()()()
Members
Icon | Member | Description
 | RaisePostEvent(EventHandler, Object, EventArgs) | Lanza el evento que le es pasado como parametro de forma asincronica usando un contexto de sincronizacion
 | RaisePostEvent<(Of <(T>)>)(EventHandler<(Of <(T>)>), Object, T) | Lanza el evento que le es pasado como parametro de forma asincronica usando un contexto de sincronizacion